Couldn't delete this file

Hi everybody,

Is the option "Delete this file" working for you?

It is not working for me, I'm always getting the message "Couldn't delete this file"

I'm root, DIG should have the permissions for deleting the files, but maybe I'm missing something.

Thank you.


  • I have that problem too.

  • Same here... I've a .cue file that I wanna delete, but every time I try from DIG, this error appears...

  • I don't know what permissions Dig would have on a rooted device; I don't have one to test it.

    For all of you, what version of Android do you have and where is the file located (device, SD card, network, etc) ?

  • I'm unsure of android version. Using a Sony Bravia android TV with games on an external USB hard drive. I've noticed file manager apps have no write permission. Dig seems to have permission to download images and the game details which are being saved to the USB drive but not delete. So for me it could be the drive causing the problem

  • Im usind android 7.0 and the files are in my sd.

    Dig has no problems writting there since I'm keeping all covers, themes and screenshots in the sd card.

    I've checked the permisions for one if the files I want to delete : -rwx-xr-x (755)

    Maybe that helps.

  • Same problem here.

    I have a Samsung Galaxy S10 and the ROMs are on SD card.

  • Sorry for the typos. It is hard to type from my phone. The right permissions are -rwxr-xr-x (755)

  • If the files are in Android/data/com.digdroid.alman/files on any device Dig has full permissions. If they are anywhere else on the device Dig may or may not have write permission depending on the device and version of Android.

  • All my roms from my sd are in /roms/... not in /android/data/... I will check that

  • edited August 2019

    Ok. I see the problem.

    /Android/data/com.digdroid.alman/ is owned by DIG, there, DIG can rwx

    /roms is owned by root and there DIG can only r-x

    I haven't found a way yet for changing /roms ownership or permissions.

    I could move all roms to the DIG ditectory and that would fix the problem but at the moment I prefer to keep my sd folder structure.

  • edited August 2019

    I found a solution for this. I guess it is more related with how Android manages permission than with DIG itself.

    First of all, if you want to follow what I did do it at your own risk. You are messing with permissions here so there is a real risk of breaking things.

    Second, I use android 7.0 on a gpd xd + and I want DIG to have access to the /roms/ folder in my SD card formatted as FAT32, If your situation is different I cannot tell you if this will work for you.

    Third, by default, If you configured DIG for using your SD card, DIG can create and delete files located in /Android/data/com.digdroid.alman/ (in your SD card) this means you can always move your roms to /Android/data/com.digdroid.alman/ and you should be able to delete files without following this guide. What I did allows DIG to create and delete files (write access) anywhere in the SD card.

    Fourth, you need to be root.

    If everything is clear and you still want to try, do the following:

    1- Make a copy of /data/system/packages.xml and keep it as a backup just in case something goes wrong

    2- Edit /data/system/packages.xml and look for the digdroid section

    3- Under the digdroid section, inside the <perms> node add the following line

    <item name="android.permission.WRITE_MEDIA_STORAGE" granted="true" flags="0" />

    and save.


    That worked for me.

  • I tried this and it bricked my device. It won't get past the "Android" boot screen now.

Sign In or Register to comment.