"There's not enough free space for the copied or extracted files" when using RetroArch (MAME)

I can't start a game using the core RetroArch (MAME 0.223). The game must be executed in a zip file or otherwise it won't start.

The rom runs fine directly in RetroArch but not on DIG, which is very frustrating.

In DIG I assigned the correct core to RetroArch (MAME) which is "mame_libretro_android.so".

Comments

  • Which game is it?

  • Hi, thanks for replying. Its actually not a specific game but all "MESS" related systems. As an example "AdventureVision", in RetroArch it's a folder called "advision" and inside there are the games zipped. DIG does find the artwork for that system and its games but if I want to execute one I will get this error "There's not enough free space for the copied or extracted files".

  • edited October 16

    Mabye this issue happens because MAME needs to run two zip files at once, the BIOS zip and the game itself.

    In MAME the files are located like this:

    ./roms/advision/defender.zip ---> game

    ./roms/advision.zip ---> bios

  • Can you fix this issue in the next update please?

  • Are you using Android 11? If so I think I know what the problem is.

  • I'm running Android 10.

  • Could you open RetroArch, go to Settings > Directory, and tell me the setting for System/BIOS? Thanks.

  • My System/BIOS directory is located to my secondary SD card, I have put all my BIOS files in a folder called "BIOS":

    /storage/170B-425C/BIOS

    I also tried to put and locate the BIOS folder on internal storage, unfortunately there's no difference.

  • I also tried with another device, which is running android 10, same error issue on DIG.

  • Try "Reset RetroArch config" under App options. If that doesn't work do the folders MAME/hash and MAME/roms exist in your BIOS folder?

    Also try setting the System folder to the RetroArch default (RetroArch/system). Remember to reset the config after making the change.

  • Hi, RetroArch works normally, I can play all MAME related systems and yes MAME/hash exist in my BIOS folder. The roms do not to be inside the MAME folder.

    The issue is that the DIG frontend can't launch RetroArch for that specific MAME core. All other cores do work.

    It's a bug in your frontend and not RetroArch, so please fix it.

  • edited November 1

    In DIG I just tested the Arcade section and set under "Manage system" "RetroArch (MAME)", the same core I would use for "Adventure Vision", and fired up the Konami Aliens (1990) and the rom is loading correctly, which means DIG can handle this core and it's not a directory or permission issue.

  • DigDig
    edited November 1

    Systems like Adventure Vision are handled very differently by Dig than arcade ROMs. Please try my suggestions - it will help me track down the problem.

  • Ok, I've found the error:

    When I put the roms into internal storage:

    /storage/emulated/0/RetroArch/roms/...

    and System/BIOS:

    /storage/emulated/0/RetroArch/system/...

    the system Adventure Vision using "MAME (Retroarch)" works.


    That means, all related MESS systems (Adventure Vision, Super Cassette Vision, Bally Astrocade, Fairchild Channel F, Odyssey2, Intellivision...) only run with the internal storage when using DIG frontend.

  • Not exactly, only the folder the System/BIOS setting points to needs to be in internal storage or otherwise has write permission. You may leave the ROMs anywhere that has read permission. Dig will create temporary copies in the System folder as needed.

  • Ok, I will redo everything from scratch as you told and let you know...

  • Ok, I've found out that on MESS/MAME related systems DIG needs also to have the roms inside the internal storage BIOS/System directory, otherwhise the games won't start up.

    Here's a directory example:

    /storage/emulated/0/BIOS/mame2016/roms/casloopy

  • DigDig
    edited November 2

    I have my game and BIOS ROMs on a SD card on one device, and on a hard drive on another device and they work fine so something else is the problem. Did you remember to reset the RetroArch config after changing the System/BIOS folder?

    You shouldn't need to set up any files or folders. Just leave your files anywhere Dig can see them, make sure Dig knows where the BIOS files are - the easiest way is to keep them with your game files - and DIg will do everything for you.

Sign In or Register to comment.