Dreamcast titles suddenly appear as Naomi and can't change back

So I have a bunch of Sega Dreamcast titles which in previous versions of dig have been showing up as Sega Dreamcast but all of a sudden they started appearing under Sega Naomi which is now requesting that i install yet another emulator how do I change these titles to go back on the Sega Dreamcast and not under Naomi. this is especially frustrating as I have reicast installed from the app store yet under Naomi it's insisting install the different version of riecast from retro arch

Comments

  • Hi, this same error occurred to me with some PS1 games. For some unknown reason, some games could be mismatch. To fix this, I did the following: go to Naomi System, tap options button, config systems, ROMs path, and remove all mismatch folders. After this, go to Sega Saturn System and do the same thing, except you don't remove folders, you add the folder where the games are.

  • edited May 12

    Sorry, I've duplicated post. Ignore this one 😅

  • I did this, and yet later I come back and Dig has moved some Playstation 1 games to Saturn and PS2. I've tried fixing it twice but it doesn't stick.

  • The problem seems to be with systems with games stored in subdirectories. I choose the parent folder as the system rom path, such as "SD Card/Games/psx/" and then when it scans the directory, it adds all the subs as separate rom paths. Later, Dig will move some games to Saturn and delete them from the list of rom paths for PS1. When I delete the rom paths from Saturn and Add an empty "saturn" folder, Dig won't store it because there are no games in there. But Dig won't add the migrated games back into PS1 list with a rescan either. I have to manually add those subdirectories for the migrated games myself.

    This is a genuine bug in need of fixing, methinks.

  • Just now I opened Dig and it went through and moved some of my PS1 games back to Saturn and PS2. Very frustrating.

    It would be nice to get a response from the Dig developer, as it's delaying my progress of building a retro gaming device.

    These are the games it keeps happening to:



  • Hi guy, how are you? Are you using the beta version? I've this problem with the normal version, but recently this bug appears to be fixed in the beta version. On the first run, it detected some PS1 games as Naomi, but after a restart, it detected right.

  • Just wanted to update, this hasn't happened again, but only because I told Dig to ignore Saturn and PS2. Dig still wants to put 10 or so PS1 games in those folders, so they don't automatically add to PS1 with a scan, I have to add them manually, individually, which is a pain navigating through my directory structure from the top level every time.

    I'm also annoyed that the developer has been ignoring this thread while addressing other people's problems. This can't just be an isolated problem with my phone...

  • With the latest beta I just uploaded can you try adding your root ps1 folder to your ps1 path list? It doesn't matter that it's there already, add it anyway. If that doesn't work can you send me the full paths of the files of some of the games causing problems? Sorry for the delay.

  • That seemed to do the trick, but now Dig crashes every time I use the Recent Apps button on my S9+ to switch to another app and then switch back to Dig.


Sign In or Register to comment.