Error: Couldn't find game in database


Been using Dig for a few weeks and love it. Perfect for phones and very easy to use!

However after a few days/weeks use, I start to get this error whenever I select a game.

"Couldn't find game in database. Doing a rescan may fix the problem."

It then removes the game from Dig (I have to unhide the game to get it back). This happens with all games in my library.

My roms are on my local sdcard so the files are definitely there.

Rescan does not fix it. The only fix is clearing app data and rescanning my whole library again from scratch.

I'm not sure what triggers it. I suspect it might be when the app updates, although I'm not 100% sure. It just happens at some point after a fresh install (days/weeks).

I'm using a OnePlus 6T with Android 9 and OxygenOS 9.0.12.

Any thoughts? Any logs i can send to help pin point the issue?

Many thanks.


  • Someone else had this problem and I thought I found the bug that caused it but maybe not. How many times has this happened? Prior to it happening did you ever do a restore from a backup?

    For now I suggest doing a backup and saving the backup file somewhere safe. If this happens again please do a backup immediately and send me that backup file. Then after resetting you can try restoring the good backup.

  • Thanks for the quick reply. I actually have the error now. This happened 2-3 weeks ago and I haven't done a fresh install since. I made a back up and will send it to you via PM (Not sure if there is any sensitive info, so not keen on attaching it here).

    I would say since I first got the app a couple of months ago, it's happened 3 or 4 times. I haven't tried restoring from backup but will do a fresh install and and make a backup for now.

    I also turned off auto app updates, so I can check before and after the next Dig update to see if it is related to that.

    Thanks for you help.

  • I looked at your database and I couldn't find anything obviously wrong. I made a change in the new beta I just uploaded but I'm not sure if would help your problem. If it doesn't can you try enabling 'Skip game info' and tell me what happens?

  • Thanks for this.

    Interestingly I fresh installed and restored from the 'bad' backup I sent you and all worked fine. So the issue does not seem to be related to the database.

    I also just updated to the latest release of Dig and all still working fine. So either the issue is fixed or it's related to something else.

    In any case I'll keep an eye on it and try Skip Info if it happens again.

    Thanks again for your time looking into this!

  • I've got the same problem. It always happens after an update.

    I also have all my roms on an SD card so maybe it is related to that. I heard that Android is kinda weird with permissions and SD cards.

  • This finally happened to me! It looks like something goes wrong during the "Completing installation" process. When this error is detected I'll force Dig to redo the "Completing installation".

  • This also happened to me yesterday, (Error completing installation) after updating to the latest Beta version. I had to leave the Beta and install the stable version, which meant reinstalling the database etc.

    Is there a workaround solution if it happens again?

    I'm relatively new to Dig, but I'm loving it, and I really appreciate the Dev's efforts.


  • Hopefully the latest beta will do a better job of recovery. It also does a backup when it detects the error so in the worst case you can uninstall, reinstall, and restore from the backup.

Sign In or Register to comment.