Still looking for answers

I've previously asked these questions but they were ever answered so trying again.

1. How do I use kiosk mode. It just gives me a message telling me to open something with a joypad but it's not too clear what. I am.using a joypad.

2. How do I start amiga games? My files are all adfs. The retroarch puae doesnt open and the other emulator opens but without the adfs inserted

Comments

  • Ok update

    1. Started working when I changed theme. Now I'm happy to let my kid play without worrying about changing settings

    2. Uae4arm I had a typo in the path to the dig config. Corrected it and now the emulator starts with my adfs selected but doesnt set the other options (kickstarter and memory etc) . Is this possible or do I need to manually set them everytime I load an adf?

  • The only way to exit kiosk mode is from the navigation drawer (the panel that slides in from the left). So if you're using a gamepad I want to make sure you have a button assigned to open the drawer.

    Dig creates configuration files for the game for the Amiga 500 and Amiga 1200. I believe the A500 is launched by default. To load the A1200 config back out and double tap it. The A500 config uses Kickstarter 1.3 and A1200 uses 3.1. If they are in a ROM path in the Amiga Dig settings they should be loaded automatically. If you want to use other settings you will need to do them manually.

  • Yeah I have a button assigned to get out of kiosk mode thanks.

    With the kickstarts you say amiga dig settings. So is this a setting within dig itself?

  • Yes, the folder(s) your Kickstarts are in should be in the "ROM paths" in Amiga's "Manage system" menu to be loaded automatically.

  • Still no luck with the auto kickstarts.

    I have my kickstarts in a folder in Dig/Emu config/UAE/kickstarts

    In UAE4ARM the path for kickstarts is pointing to this and I can select the different kickstarts from the dropdown list.

    In Dig under manage system -> Rom paths I have the game paths set and have also added the kickstart path.

    When I launch a game the uae config files are created (default, a500 and 1200) with all the correct adfs but the kickstart field is blank.

    If I go back to the menu I can manually select the kickstart file from the dropdown list.

    I have kickstarts 1.3 to 3.1(a500 and A1200 versions) and the ones in between.



    As an extra cheeky question, as uae4arm can play cdtv and cd32 games is it possible to get these also added to Dig as systems? if not or until then am I able to add cd games to the Amiga collection? It doesn't seem to pick them up automatically from the folder.


    Thanks

  • The kickstarts should appear in your Amiga game list as "Kickstart v1.3" and "Kickstart v3.1". You shouldn't rename them but you can ignore them. If they don't have these names try renaming them as such (the Dig titles, not the file names).

    I will certainly look into adding those systems.

  • Thanks.

    My kickstart roms havent been detected. It may be that the folder hasn't been scanned yet as I'm currently rescanning all my games after my hdd rename issue.

    I have thousands if c64 and spectrum games to get through so I'll be patient and just manually change till all the folders have been checked

  • My kickstarts were finally scanned and are now auto detected when I start the emulator. Thanks for helping with this.


    1 final question relating to the amiga games and uae4arm, would it be possible to give an option to select if a rom opens with a1200 or a500 settings? I know with PUAE you can add a1200 or aga to the name to auto start in a1200 mode but puae is too slow.

  • Arrrgh now I'm having the reverse issue. My roms are found but my games aren't.

    So I dunno if you saw in the other thread about my hdd changing name, but I've had to format the drive and put all the games back on. This gave it a completely different name but its work fine. However I tried an amiga game and it loaded the kickstart rom but not the game. I went into the menu and theres nothing in the df0 and when I try to use the file browser it is set to the dig emu config folder and it won't let me go to the external drive.

    I checked the created uae files and they have the correct path and file name in them

  • edited September 9

    May have figured it. I formatted my drive as ntfs and I don't think uae4arm can see it


    Edit: yes it was ntfs worked out how to get latest uae4arm on my tv and it's fine now

Sign In or Register to comment.