Retroarch issue with Dig (on devices with physical buttons)

Hey all,so I prefer seperate emulators to using retroarch but some systems emulators simply dont exist so been forced to use retroarch and download any cores needed.

Prob is,how do you exit the damn thing while in Dig for eg.

In Dig with stand alone emulators I just press back and itll back out,exit the emu back into Dig.

But this doesnt work with retroarch. Only way I can exit is to press home key and kill it.

I even lauched retroarch,tried to map the quit retroarch function to a spare key on the JXD S7800 but doesnt seem to work.Have I missed something? Anyone can elaborate on the steps I need to do just to make sure Ive done it correctly? Or perhaps retroarch just doesnt work properly with devices like the JXD and others that have phsical buttons?


  • i am using an ipega 9076 controller with an mxq box and when using retroarch emulators i press start and select to take me back to the retroarch menu when playing a game,you can then go to quit retroarch to take you back to the dig homescreen, thats what i have been doing.

  • edited June 2019

    You can map a physical button if you have a free one to exit Retroarch by going into the input menu and assigning it in the hotkeys menu.

    I use a device with physical buttons but they are all used so i actually don't have a physical button to exit so i use a virtual button to exit using my custom retroarch overlays:

    It works pretty nice too.

  • If you don't have free buttons to map Retroarch quit shortcut, you could use the "Enable Hotkeys" function. With this, you could map shortcuts to any previous mapped buttons, and it will only enable the shortcut if you hold the "enabler". I usually map Select as Hotkeys enabler, L1 to Retroarch menu, L2 to quit Retroarch. Once you Master this feature, you'll ask why standalone emulators doesn't have something like this 😅

    This thing could be accessed from Config > Input > Hotkey Binds.

  • Hey I said.I tried mapping a key but when trying it just doesnt do anything.

    (Start Select together also does nothing)

    And yeah,I also went to enable hotkeys,successfully enabled hotkey buttons..enable hotkey and one to quit retroarch.

    But when I tested,hold the hotkey and the button I assigned quit nothing happens.

    But....If I use retroarch alone,as in launch retroarch app and start a game that way it does work,so I guess I wasnt doing anything wrong? But if I launch a game through Dig and it then it launches retroarch THEN it wont work for some reason.

  • Got it sorted.

    In Dig I went to options/app and selected Reset Retroarch config.

    Seems to be working now,

  • I am running Dig on my Nvida shield tv, My only two complaints are:

    1. Everytime I try to download new box art it says "you don't have an app that can do this" I tried installing a web browser to my system (tvbro) and just opens the broswer and does not give me an option to download/save the box art.

    2. I go to start up a dreamcast game and it Crashes right back to the Dig game screen, I have the emulator set as "Retroarch Reicast"(Dreamcast games run just fine when I play them right from Retroarch)

    Please help!

    1. This requires a browser that allows you to download images, but unfortunately Shield doesn't come with any browser at all, and I haven't found one yet for Android TV that allows image downloading. You could download them on a computer or other device and transfer them to your Shield.
    2. First check that "Use RetroArch64" is set to the version of the core you have. Then try resetting the retroarch config. If it still doesn't work I'm not sure what could be wrong.

  • edited June 2019

    I know that Android TV works slightly different from the common version for mobile, but if he installs Aptoide, then install Firefox from it, could this help him with this issue? Isn't a permanent fix, but could be a workaround solution.

Sign In or Register to comment.