Dig cannot find scummVM games


I added some scummVM games to my rom collection. As dig nor Retroarch could not find the in zip form, I unzipped them in separate folders then manually added all the corresponding .scummVM files in each folder (what a chore !). Now Retroarch finds most of them, but Dig still show no result. I don't know what to try anymore, ideas someone ?

For info :

  • running 1.38 beta 2 on a Nvidia Shield
  • Files stored on a NAS => with recent versions of android on the Shield, network shares are read-only, I don't know if it is possible to turn on R/W


  • Hi, still have not managed to make it work.

    Anyone has an idea on how ? is Dig supposed to support zipped ScummVM games ?

    If yes do I still have to create the .scummvm file ? Inside or outside the zip ? And does the zipped games have to be put in separate folders ?

    If someone who managed to make it work can share the information, I would be grateful.

    For you interest, I have been trying my game collection with the windows version of scummVM on the same shared folder and they all work perfectly. On my Shield TV, most of them can be run manually from Retroarch in their unzipped form qith the .scummvm file, but my Dig still does not detect any game (while it detects dozens on other systems in the same shared folder without a problem).

    I really have no idea what else to try to make it work.

  • Have you scanned the folders manually or just the autoscan? Mine didn't find the games with autoscan but manually worked fine

  • If you mean adding the folders manually in the "manage emulator" menu and scanning from there, I tried many times, either by adding the root directory of my scummVM rom collection, or just a few of them directly...

    I wonder what Dig is looking for when scanning this type of games. Is it only the .scummvm file or other checks are performed ? Does the file has to be written by Dig itself (which is not possible as the folder is shared on a NAS, therefore forced read only by AndroidTV), or my manually created one should work, I have no idea.

  • That's what I meant yes.

    The way I have it set up is all my games are unzipped into folders that are named as the game.

    I then scan the root folder that contains the scumm games.

    Then it just worked.

    This probably isnt helpful to you though because it sounds like that is what you are doing already.

  • Yes, I confirm.

    Now, to understand what's going on, I think I will just wait for the dev to drop by so I can understand exactly what Dig is looking for and how to correct my setup...

  • Just re-reading your original post and you talk about a ScummVM file.

    I havent used any ScummVM files. I'm just pointing directly at the game folders.

  • The .scummVM file is just a text file containing the short name of the game that you add inside the game folder so Retroarch can scan it in its own browser. [More info here](https://forums.libretro.com/t/importing-scummvm-games/10153)

    This allowed me to rule out a malfunction of my games collection as they are found and work properly when launched in Retroarch. They also work correctly when loaded in the windows version of ScummVM.

    Only Dig does not find them, so I would like to understand why and how to bypass this. My next try will be to move a game on a read/write folder and see if it can be found there. I will post the results. I guess it has something to do with Dig trying to write its own .scummVM file when detecting the game, but I cannot be sure without a technical specification on how Dig recognizes the games...

    If the problem is due to this, then I hope the dev finds a way to make it work on read only drives (for example by recognizing pre-existing .scummVM files) as AndroidTV cannot write on SMB shares anymore (forgot since which version).

  •  I have a similar problem with my dig when I download the Scumm Vm games from https://www.consoleroms.com/roms/scummvm and in the scan, they were not appearing so I delete the folder and created a new one and it worked. That was with automatic scan maybe you should first try with a manual like a member in the previous post told it.  

  • Currently SCUMM games are recognized only by the name of the folder they are in. I will add detection by .scummvm files.

  • Hi, updating on this issue : I had to clean my Dig install and restart from scratch, and ScummVM games came back. Not sure of what the issue was (their folders were definitely not ignored, nor the games or system), but now it works again.

    Same with a few other random systems, by the way.

Sign In or Register to comment.