Dig opens retroarch separately

So I have an older device (GPD XD) and I downloaded the 32 bit Retroarch apk from libretro’s website since they removed comparability for android 4.0 on google play so i can’t download on the play store. I’m trying to emulate GBA and I use the mGba core and on the manage system tab on DIG I have the emulator set to RetroArch (mGBA) and it is set to the 32 bit retroarch instead of default retroarch, I’ve tried both, but when I press the button to play retroarch opens in new tab and dig is not running retroarch, because when I close the retroarch tab Dig says “The core for Retroarch (mGBA) May not be installed. Launch Retroarch so you may install it now?” Any help is appreciated, and FYI I love the app bought premium just wondering if you can help.


  • First off, Dig assigns default as RetroArch 32bit, my best advice for you is to open RetroArch separately, install your preferred core with any updates needed, once your emulator is running games properly in RetroArch then go to Quick Menu> Overrides & click save Core Override & exit. Now launch Dig and manually choose the correct RetroArch Core you setup using default, hopefully that will help you.

  • Also, Dig always launches RetroArch in a separate new window (it is just a front end) but if everything is working correctly then when you Quit RetroArch (even with a Hotkey to quit), you should return to Dig

  • thanks for the advice I haven’t tried your method yet, but I use drastic and it opens drastic in the dig tab and it shows games as last played. When using retroarch it never shows as last played

  • No problem...Dig & RetroArch store there recently played games separately from one another so launching a game from standalone RetroArch will never update Dig's [Recently played] & vice-versa

Sign In or Register to comment.