Nintendo DS not launching from DIG since last Drastic update.

Just as the title says DIG doesn't seem to launch into the Drastic emulator since Drastics last update(?) from the play store.

The thing is i haven't launched any ds games from DIG for a couple of months now (busy making themes😉) and i remembered them launching just fine with no hassle and today i go to play a ds game and it just wouldn't work at all and all of my configurations seem to be normal so i figured it must be from some kind of update from Drastic that's causing it.

Is it just me and perhaps it's something wrong on my end or is anyone else experiencing this too?

Comments

  • Just checked mine.

    Launched through Dig just fine for me.

    What version of Drastic are you running?

    Latest version for me is showing r2.5.2.0a

    Is yours same?

  • edited January 25

    My version of drastic is the same. It must be something on my end I suppose.

    DIG now boots into the drastic main menu now all of a sudden where as before it would just go to a white screen and instantly close back to DIG. It was working just fine like a month or so ago and I haven't done anything to change that to my knowledge. Oh well I guess I'll have to tinker around with things a bit more and hope it works.

  • I tried an older version of DraStic(r2.5.1.3a) and it worked fine with DIG which means something happened in the last update of DraStic for it to not work for me.

  • Checked again.

    Yep,works fine for me.

    When using Dig,I go to NDS system,select a game...goes to white screen and then game launches just fine.

  • Oh well it must be my phone or something but it's working perfectly now with the older version of DraStic.

    By the way this also happens to me but i'd like to know if this also happens to other people:If you go into a game through "Genres " and exit back to DIG is the screen black or whatever colour the background is for you and i mean like no wallpaper or anything but just one colour until you move?

  • Ha, well i guess i'm the only idiot that has these problems then.😆

    It's a good thing though that nobody else is getting these problems.

  • Same here:

    Ver 2.5.2.0a

    It does NOT work on Samsung Galaxy Note 9 (android 10) and Xiaomi Mi Pad 4 (android 8). It blinks white and then nothing... Sometimes if I click like crazy on run icon it will start a game but it's like in 1 to 10 ratio.

    It DOES work on LG G6 (android 9)

    I am kind of lost, I installed Dig and Drastic on G6 only for testing this issue, and I do need it working on Galaxy (my daily driver) and on Mi Pad...

    Help!

  • I'm having this problem, too. I'm running on a GPD XD+.

    It worked fine a couple of months ago, but now Drastic won't start.

  • Hi

    This situation happens to me but using the DamonPS2 PRO emulator .


    I bought the pro version in PlayStore ,both DamonPS2 PRO and DIG with premium fractures unlocked.


    But although I set the DamonPS2 pro un Game settings to launch the Game selecting this emulator , a opo yo screen appears saying that something wrong happens with this emulator ...


    I do not know how to solve It ...



    Thanks!

  • This looks like some priority problem and can be possibly fixed on frontend side?!

    Just noticed this: it just looks like game blinking white and nothing happens. But if you pull your finger from abowe-top-screen Drastic is in notification panel and game is loaded. All you need to do is to pull notifications down and click on drastic. Any option to force dig to "hide in the backgrond" after launching a game?

    Any DIG dev here?

Sign In or Register to comment.