New update has many issues

I'm on Android 12 and the last version of Dig worked perfect. The new version 1.40 has a ton of issues. All seem to be permission related. I can't change box art or any icons (similar to other people). When retro arch loads it's complaining about not having a config directory.

All the Android apps are gone, except RetroArch.

Everything worked great in the previous version.



  • One of my emulators had roms outside of the RetroArch folder. All those roms went missing after update. I had to remove the rom path. And then readd it. Android prompted to allow dig permissions to the folder. I said allow and then the games returned.

  • Quick update for anyone reading this with the same problems on 1.4 ...

    I found the 1.39 version of Dig on APKPure ... uninstalled 1.4, installed 1.39, restored from backup .. .and in about 5 minutes I was back up and running perfect. Everything working great again.

    Just have to stop the play store from auto-updating it to 1.4....

  • Same issues, + if you cloned a system, the art work must now be in a folder called clone2 for example for it to be recognized.

    also, many aspect ratio issues even with the hack option enabled. Mostly the game selection screen, the play button is gigantic.

  • edited February 2022

    It was a lot of issues. Overall, version 1.4 seemed to be totally broken on Android 12.

    Just downgrade back to 1.39 and it's all perfect again.

    Hopefully 1.41+ will tested better.

  • edited February 2022

    For me the new v1.4 is completely broken & thanks for that info regarding v1.39, I've had to revert back and disable auto updates.

    Btw, if anyone needs to uninstall & revert back to a previous version then make sure your Roms and/or Boxart are not in any Dig folders.

  • Someone needs to implement Capcha on posts. The forum is getting flooded.

  • after the update of 10 August 1.42.3, games no longer start on smartphones and also on Android TV.

  • You need to turn off the net and wifi then games will load, a really bad bug. Hope Developer fix this soon

  • Sadlly after months the latest version. Is still broken, i stay with 1.39 that works perfect even on android 12.

Sign In or Register to comment.